WordPress requirements

All HostPapa servers fully support the hosting of WordPress websites. The minimum server requirements for WordPress are as follows:

  • PHP 5.6.x or above (PHP 7 recommended) 
  • MySQL 5.6 or above 
  • The mod_rewrite Apache module
  • HTTPS support

We also offer a free SSL certificate from Let’s Encrypt to secure your WordPress website.

If you need help with your HostPapa account, please open a support ticket from your dashboard.

Related Articles